Spigot 1.9.2 - Der ausführlichere Updatebericht

    • Update
    • MC-Server

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Spigot 1.9.2 - Der ausführlichere Updatebericht

      Hallo zusammen,

      die gestern Anwesenden und Mitleser des Forums wissen es bereits: Unser Server läuft nun auf der Version 1.9.2.
      Dies bedeutet im Klartext, dass alle Clients der Versionen 1.9.0 bis 1.9.2 auf dem Server joinen und spielen können, die nachfolgenden Versionen sind inkompatibel. Beachtet dies, wenn ihr eure Mods updaten möchtet und weiter auf dem Server spielen wollt :)


      Der ursprüngliche Plan, direkt auf 1.9.4 upzudaten musste leider verworfen werden, da Denizen noch nicht soweit ist und damit unsere Quests nicht funktionieren würden. Wir werden das Update auf diese Version durchführen sobald sich hier die Lage ändert.
      Mit dem Update ergeben sich zum ersten Mal seit langem auch wieder ein paar Inkompatibilitäten, da zur 1.9 Dinge verändert wurden.
      Im der Nachricht zur Serverwartung wurde das Problem mit den Teleports bereits angesprochen, Details möchte ich im Einzelnen weiter unten erläutern. Zur Beruhigung: Das Portalplugin funktioniert wieder einwandfrei.

      • Ports: Das Portalplugin funktionierte bislang ohne Update, zur 1.9 spuckte es nun Fehler en masse aus. Die Ursache war allerdings lediglich ein Teil (Metrics), der in den meisten Plugins eingebaut ist und Statistikinfos an mcstats.org sendet. Dieser hat sich verändert, alle Plugins die dies beinhalten und nicht mehr geupdatet werden zeigen somit dieses Verhalten. @Bluekey hat uns diesen Part entfernt und das Plugin läuft wieder einwandfrei, damit wird es in seiner Überlebensdauer nur von iConomy übertroffen ;)
      • Voxelsniper: Ist gerade das Sorgenkind, da @Itlau und @Tolkier die Vorbereitungsphase für ihr Projekt eingeleitet haben. Voxelsniper 5 in der Version für die 1.9 funktioniert nicht und wirft Fehler aus, die alte Version funktioniert, spammt aber Metricsfehler. Ich habe mich daher dafür entschieden den neusten Voxelsniper 7 Build zu nehmen, welcher auch funktioniert, der aber noch in seiner Funktionalität nicht an die ältere Version herankommt. Die Lage wird im Auge behalten und Lösungen gesucht, sobald Probleme mit dem Funktionsumfang auftreten.
      • Commandblöcke: Die Commandblöcke bringen zur 1.9 einige neue Features mit; die Dungeons werden daher gerade von @LKGLS überarbeitet. Er wird vermelden, wenn diese Arbeiten abgeschlossen sind. An dieser Stelle nochmal vielen Dank an @LKGLS für die zügige Einrichtung eines Notportals am Spawn via Commandblöcke, während das Pluginproblem behoben wurde.
      • mcMMO: Es kam gestern zu Verwirrungen, da die Spezialfertigkeiten offensichtlich nicht verwendbar sind, wenn die Zweithand mit einem Item belegt ist. Sollte es hier ein Update geben, welches das behebt, werde ich Bescheid geben, bis dahin achtet darauf die zweite Hand leer zu lassen, wenn ihr den "Green Terra" oder andere Skills verwenden möchtet.
      • Alle anderen updatebaren Plugins wurden ohne Probleme auf den neusten Stand gebracht.
      • Das End: Wurde noch nicht geupdatet. Bislang ist auch unklar, in welchem Rahmen es zugänglich gemacht wird. Da der Wunsch bei einigen durchaus besteht, werden wir einige Ideen sammeln und uns etwas Sinnvolles dazu überlegen. Vorschläge zu neuen Votebelohnugen sind in diesem Zusammenhang auch gerne gesehen.
      Soweit zum gestrigen Update.
      In näherer Zukunft ist neben dem Update auf 1.9.4 auch das Ausmisten der Permissions angedacht. Sollten allgemeine Fragen bestehen können sie gerne in diesem Thread gepostet werden, mit den Voxlern werde ich über das TS Rücksprache halten.

      Ich wünsche allen eine gute Woche und frohes Craften.

      - SilberRegen für Craftasy
    • Da die Inhalte des Ends nun sogar Anreize bieten, sich diese auch zu schnappen (Endziegel erscheint mir zum Beispiel als eine nette Option für Quadesh), wäre es wohl am besten, wenn man es ähnlich handhabt wie auch mit den anderen Zusatzwelten, wobei ich aufgrund der geringen Nützlichkeit (soviel neuen Content gibt es dort nun auch wieder nicht und quantitativ überwältigt fühle ich mich jetzt nicht) einen Preisbereich zwischen den beiden Fixpreisen der bereits gängigen Portale vorschlagen würde, sollte man denn auch hier die Portallösung näher in Betracht ziehen.
      Dark humor is like a child with cancer - it never get's old!
    • Nach einiger Arbeit kann ich nun erfreut verlauten lassen, dass die Dungeons wieder einwandfrei funktionieren. Außerdem habe ich mehrere kleinere Fehler gefixt:
      • Chatping hat wegen den 1.9 Soundupdates nicht mehr funktioniert, läuft jetzt aber wieder einwandfrei (/chatping)
      • Kleinere inhaltliche Fehler in mehreren Quest-Skripten wurden korrigiert
      • Script "unzerstörbare Boote" wurde entfernt, da es nun mit den 1.9 Booten überflüssig ist
      Ich kann jedoch nicht garantieren, dass ich nicht irgendwas vergessen oder übersehen habe, wenn ihr also irgendwo Probleme habt, sagt bescheid und ich kümmer mich drum. Insbesondere beim antiken Schrein (Nordöstlicher Zelda-Dungeon) könnten Performance-Probleme auftreten, sollte dies der Fall sein, sagt mir bescheid und ich knöpf mir den Dungeon nochmal vor ^^
      It's dangerous to go alone, take this signature!

      >Blackshire< ist fertig; >Bluchenfels<, jetzt bist du dran!!!